IDEXX Payments error in Neo

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 11:59 EST

Monitoring

A fix has been implemented and transactions are able to be processed again. We'll continue to monitor the system.
Posted Dec 15, 2025 - 11:15 EST

Identified

The Neo team have identified an issue impacting IDEXX Payments. We are working on applying a fix and will provide another update within the next hour.
Posted Dec 15, 2025 - 11:04 EST
This incident affected: Neo (Neo Software).