Some Cornerstone practices are unable to login to Vello

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 13:56 EDT

Investigating

We've identified an issue that is blocking some Cornerstone practices from logging into Vello. No other functionality is affected and pet owners are still able to access Vello.

We've found the root cause and are working on a fix.
Posted Aug 17, 2026 - 12:32 EDT
This incident affected: Vello (Cornerstone Vello).