Web PACS - Unable to Import/Export Images

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 16:30 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2026 - 14:30 EDT

Update

We are continuing to investigate the issue with Import and Export, and are now also looking at issues with loading patients and images. We will update shortly.
Posted Jul 17, 2026 - 13:56 EDT

Investigating

WE are currently investigating an issue with Import & Export functionality in Web PACS.
Posted Jul 17, 2026 - 13:04 EDT
This incident affected: Diagnostic Imaging (IDEXX Web PACS).