EUW1 Performance issues 18/10 13:10

Incident Report for IDEXX Software

Resolved

The performance issues that you experienced with your ezyVet site are now resolved. We apologise for the impact that this problem had on you and your team, and we thank you for your patience whilst we resolved this.
Posted Oct 18, 2025 - 10:30 EDT

Investigating

We are aware, and our Platform engineers are currently working on resolving the performance issue impacting the EUW1 server.
Posted Oct 18, 2025 - 08:26 EDT
This incident affected: ezyVet Software (ezyVet Software: Europe/Middle East/Africa).