AWS Outage

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 16:21 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 00:11 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:56 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 16:55 EDT

Investigating

We are currently experiencing a service disruption with VetConnect PLUS that may impact your experience. We apologize for any inconvenience this may cause; our team is working to resolve it as quickly as possible.
Posted Oct 20, 2025 - 16:04 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:12 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 08:52 EDT

Update

We are starting to see further recovery but are still experiencing degraded performance. We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 07:33 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 07:02 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 06:29 EDT

Monitoring

You will experience an error when submitting an IDEXX Diagnostic Order within VetConnect PLUS and your Integrated Practice Management Software. Our team has reported the issue to Amazon Web Services who is currently working on resolving the issue.

As always, IDEXX appreciates both your business and your patience. We apologize for the current interruption in the ability to order IDEXX Diagnostics and for any inconvenience this may cause.

We will provide an update no later than 7:30am ET on 10/20/25.
Posted Oct 20, 2025 - 06:28 EDT
This incident affected: VetConnect PLUS Ordering (VetConnect PLUS Ordering, SmartService) and VetConnect PLUS (Diagnostic Results, Web, Mobile).