Neo: Open consultations cannot be closed or marked "ready to pay"

Incident Report for IDEXX Software

Resolved

A fix has been implemented and this incident resolved.
Posted Sep 17, 2026 - 12:46 EDT

Identified

The Neo team is aware of an issue when you click Close Consultation or Ready to Pay at the bottom of a consultation, the consultation is not closing and you receive an error.

Until this issue is resolved, you can enter any payments as a prepayment.
Posted Sep 17, 2026 - 12:31 EDT
This incident affected: Neo (Neo Software).