Ordering resources were increased to handle high latency, and performance has recovered. We will continue to monitor to ensure recovery is stable.
Posted Apr 02, 2025 - 15:50 EDT
Investigating
You may experience increased error rates and/or high latency when submitting an IDEXX In House Diagnostic (IHD) Order or an IDEXX Reference Lab Diagnostic Order within VetConnect PLUS or your Integrated Practice Management Software. Our team is investigating the issue.
As always, IDEXX appreciates both your business and your patience. We apologize for the current interruption in the ability to order IDEXX In House Diagnostics and an IDEXX Reference Lab Diagnostics for any inconvenience this may cause.
We will provide an update no later than 4:30 PM ET on Wednesday April 2nd.
Posted Apr 02, 2025 - 15:39 EDT
This incident affected: VetConnect PLUS Ordering (VetConnect PLUS Ordering).