ezyVet - Performance Issue with Global Search Function

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 18:15 EDT

Identified

Our technical team have identified the root cause and are currently implementing a solution to resolve this issue.

Thank you for your continued patience.
Posted Apr 28, 2026 - 17:58 EDT

Investigating

Our technical team have identified an issue with the Global Search Bar and are currently investigating. We are currently working to further understand the problem and diagnose the cause. As we have further information available we will provide additional updates.

We appreciate your patience while we investigate.
Posted Apr 28, 2026 - 17:50 EDT
This incident affected: ezyVet Software (ezyVet Software: USA and Canada West, ezyVet Software: USA and Canada Central/East, ezyVet Software: Australia, ezyVet Software: New Zealand, ezyVet Software: Asia, ezyVet Software: Europe/Middle East/Africa).