ezyVet Third Party Integration Issue
Incident Report for IDEXX Software
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 10:25 EST
Investigating
The ezyVet Academy platform (Absorb), one of our third-party applications, is currently experiencing performance issues. This is affecting the ability to utilize the Academy. Please contact Absorb directly for further details.
Posted Nov 18, 2024 - 15:40 EST
This incident affected: ezyVet Software (ezyVet Academy/Absorb Platform).