Pet Health Network Pro: Degraded Performance / AWS Outage

Incident Report for IDEXX Software

Update

All systems are fully operational. We continue to work through a backlog of data to process in order to reflect the most current information in automated communications and pet owner portals/mobile apps. We continue to closely monitor the system.
Posted Oct 21, 2025 - 14:10 EDT

Monitoring

We continue to monitor Pet Health Network Pro system recovery as the AWS outage has been resolved.
Posted Oct 20, 2025 - 19:50 EDT

Identified

Pet Health Network Pro services are currently impacted by an AWS outage. During this time, practices and pet owners will experience intermittent connectivity and performance issues with Pet Health Network Pro--automated communications may be delayed, pet owner app may be unaccessible, 2-way texting may be delayed or unavailable, and similar. We will continue to monitor and respond to AWS recovery efforts.
Posted Oct 20, 2025 - 06:48 EDT
This incident affects: Pet Health Network Pro (Petly Pages, Texting, Mobile App, Pet Health Network Pro).