Unable to View Images

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 18:11 EDT

Monitoring

Systems are stable now and we are continuing to monitor the system.
Posted Jun 03, 2025 - 17:07 EDT

Identified

We put in a temporary fix and we are monitoring the system.
Posted Jun 03, 2025 - 16:33 EDT

Investigating

We are currently experiencing the inability to allow users to view images within IDEXX Web PACS. We apologize for any inconvenience. Our team is actively working to resolve the issue.
Posted Jun 03, 2025 - 15:59 EDT
This incident affected: Diagnostic Imaging (Diagnostic Images).