Neo Cloud Print Errors

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 09:49 EDT

Investigating

The Neo team is investigating reports of intermittent errors when printing via Neo Cloud Print.

Until the issue is resolved, print locally.

We will post another update as soon as we learn more.
Posted Jun 20, 2025 - 09:30 EDT
This incident affected: Neo (Neo Software).