Vello Form Links

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 18:21 EDT

Update

We are continuing to investigate this issue.
Posted Jun 30, 2026 - 15:35 EDT

Investigating

We have received reports of an issue affecting form links for some pet parents, with the user receiving a "link expired" error. The team is investigating and will provide an update as soon as we have more information.
Workaround: Workaround: Affected pet parents can connect to Vello via https://mobile.poe.idexx.com/. After creating an account, re-click the form link to access the form.
Posted Jun 30, 2026 - 15:33 EDT
This incident affected: Vello (Neo Vello, Cornerstone Vello).