Vello 2-way Messaging Inbox Intermittently Not Available

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 16:16 EST

Investigating

We are currently investigating an issue related to the Vello Inbox.
Posted Feb 20, 2026 - 15:31 EST
This incident affected: Vello (Neo Vello, ezyVet Vello, Cornerstone Vello, Texting Services).