Vello Requests & Notifications: Unable to open Appointment Request details

Incident Report for IDEXX Software

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2026 - 11:45 EDT

Investigating

We're aware of an issue affecting some customers when opening appointment request details in Vello. Our team is actively investigating and will post an update here as soon as we have more information.
Posted Jun 29, 2026 - 10:42 EDT
This incident affects: Vello (Neo Vello, ezyVet Vello, Cornerstone Vello).