Both IHD and Reference Lab Ordering Outage

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 22:17 EDT

Monitoring

Ordering systems are observed to be recovering, with the team continuing to monitor.
Posted Mar 28, 2025 - 18:32 EDT

Identified

You may experience increased error rates and/or high latency when submitting an IDEXX In House Diagnostic (IHD) Order or an IDEXX Reference Lab Diagnostic Order within VetConnect PLUS and your Integrated Practice Management Software. Our team has identified the issue and is working towards a resolution

As always, IDEXX appreciates both your business and your patience. We apologize for the current interruption in the ability to order IDEXX In House Diagnostics and an IDEXX Reference Lab Diagnostics for any inconvenience this may cause.
Posted Mar 28, 2025 - 17:21 EDT

Monitoring

Ordering systems are observed to be recovering, with the team continuing to monitor.
Posted Mar 28, 2025 - 11:23 EDT

Investigating

You may experience increased error rates and/or high latency when submitting an IDEXX In House Diagnostic (IHD) Order or an IDEXX Reference Lab Diagnostic Order within VetConnect PLUS and your Integrated Practice Management Software. Our team is investigating the issue.

As always, IDEXX appreciates both your business and your patience. We apologize for the current interruption in the ability to order IDEXX In House Diagnostics and an IDEXX Reference Lab Diagnostics for any inconvenience this may cause.

We will provide an update no later than 12 pm ET.
Posted Mar 28, 2025 - 10:55 EDT
This incident affected: VetConnect PLUS Ordering (VetConnect PLUS Ordering).