ezyVet - Issue Under Investigation - Unable to bill items due to an Error Message stating that "An Unknown Error has occurred" and "Inability to select Batch Numbers"
This issue has been resolved and the monitoring period has successfully passed. All systems are back to operational levels and functioning as expected.
Thank you for your patience as we worked through resolving this issue.
Posted Feb 25, 2026 - 19:18 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 19:07 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 25, 2026 - 19:02 EST
Investigating
Our Technical Team has identified an issue where Clinics are unable to bill items due to an error message stating that "An Unknown Error has occurred" and "Inability to select Batch Numbers"
We are currently working to further understand the problem and diagnose the cause. As we have further information available we will provide additional updates.
We appreciate your patience while we investigate.
Posted Feb 25, 2026 - 18:58 EST
This incident affected: ezyVet Software (ezyVet Software: USA and Canada West, ezyVet Software: USA and Canada Central/East, ezyVet Software: Australia, ezyVet Software: New Zealand, ezyVet Software: Asia, ezyVet Software: Europe/Middle East/Africa).