Slowness/Errors in VetConnect PLUS

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 17:38 EDT

Investigating

You may experience slowness or errors when using VetConnect PLUS. As always, IDEXX appreciates both your business and your patience. We apologize for any inconvenience this may cause and will post an update as soon as we know more.
Posted Jun 18, 2025 - 17:12 EDT
This incident affected: VetConnect PLUS (Diagnostic Results, Web, Mobile).