ezyVet Third Party Integration Issue - Zoetis Point of Care

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 17:43 EST

Identified

Zoetis Point of Care, one of our third-party integrations, is currently experiencing an issue with diagnostic results not returning. This is affecting the ability to view results in ezyVet. Please contact Zoetis Point of Care directly for further details.
Posted Nov 14, 2025 - 11:45 EST
This incident affected: ezyVet Third Party Integrations (Diagnostic Integrations).