SmartFlow Syncing Issues

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 20:17 EDT

Investigating

Our Technical Team is currently investigating a performance issue affecting the Smart Flow App and Web platform, where information is not syncing correctly across devices.

We apologize for the inconvenience this is causing and appreciate your patience. We will provide an update as soon as more information becomes available.
Posted Jul 15, 2026 - 17:45 EDT
This incident affected: SmartFlow (iPad, Web, Integration).