Issue viewing diagnostics results in Neo

Incident Report for IDEXX Software

Resolved

A fix has been implemented and this incident is resolved.
Posted Jul 07, 2026 - 16:53 EDT

Identified

The Neo team is aware of an issue impacting viewing diagnostic results within Neo.

Until the issue is resolved:
- View results directly in your diagnostic partners’ portals.

We are working on a fix and will provide another update no later than 5:00PM ET, July 7.
Posted Jul 07, 2026 - 15:16 EDT
This incident affected: Neo (Neo Software).