ezyVet Third Party Integration Issue
Incident Report for IDEXX Software
Resolved
Thank you for your patience.

The ezyVet Academy platform is now functional. You can access it here at academy.ezyvet.com

If you are continuing to receive an error whilst accessing the site, please:

-Clear your internet cache
-Close out the browser window
-Re-open and attempt to login
Posted Nov 20, 2024 - 18:25 EST
Investigating
The ezyVet Academy platform (Absorb), one of our third-party applications, is currently experiencing performance issues. This is affecting the ability to utilize the LMS Academy. Thank you for your patience while we investigate this with Absorb.
Posted Nov 20, 2024 - 11:02 EST
This incident affected: ezyVet Software (ezyVet Academy/Absorb Platform).