IDEXX Web PACS Scheduled Maintenance (3.23.11)

Scheduled for Dec 15, 20:00 - 22:00 EST

Update

We will be undergoing scheduled maintenance during this time.
Posted Dec 08, 2025 - 17:32 EST

Scheduled

We will be undergoing scheduled maintenance during this time.
Posted Dec 08, 2025 - 17:26 EST
This scheduled maintenance affects: Diagnostic Imaging (IDEXX Web PACS, Diagnostic Images, PIMS Ordering).