ezyVet Performance Issue - App Cues

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 16:09 EDT

Investigating

We are currently investigating an issue with the new Vetscan Fuse App Cues and have flagged this with our internal teams to look into further

We apologize for the inconvenience this is causing – we will provide an update as soon as we have more information.
Posted Sep 12, 2025 - 13:30 EDT