PowerScribe One - Users unable to connect to speech services

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 22:05 EDT

Monitoring

A fix has been implemented. Users should now be able to log into the application and create reports. We will continue to monitor.
Posted Jul 28, 2026 - 21:10 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 28, 2026 - 20:55 EDT

Investigating

WE are currently investigating an issue with PowerScribe One.
Users are currently unable to use the service.
Posted Jul 28, 2026 - 20:20 EDT
This incident affected: Telemedicine (PowerScribe One).