VMS - Issue Submitting Cases

Incident Report for IDEXX Software

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 04:06 EDT

Update

We are continuing to investigate this issue.
Posted Apr 21, 2026 - 04:04 EDT

Investigating

We are currently investigating this issue.
Posted Apr 21, 2026 - 04:03 EDT
This incident affects: Telemedicine (VetMedStat, VMS Pro, VMS18, VMS Admin).