Issue accessing Vello from Cornerstone and MyCornerstone

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 13:50 EDT

Investigating

We are aware of and investigating an issue with accessing the Vello inbox from the Cornerstone menu or client/patient records as well as accessing Vello Admin portal via MyCornerstone.

The Vello inbox continues to be operable and accessed at practice.vello.idexx.com while we work to resolve the direct access issue with Cornerstone.
Posted Apr 17, 2026 - 13:05 EDT
This incident affected: Vello (Cornerstone Vello, Texting Services).