Issues printing reference laboratory requisition forms in Neo

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 18:44 EDT

Investigating

The Neo Team is investigating reports of errors when attempting to print reference laboratory requisition forms.

Until the issue is resolved, requisition forms can be printed directly in VetConnect PLUS or your diagnostic partners portal.

We will post another update when we have more information.
Posted Jun 17, 2026 - 17:15 EDT
This incident affected: Neo (Neo Software).