Powerscribe One - Users are unable to connect to the service

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Aug 06, 2026 - 23:18 EDT

Monitoring

A fix has been implemented. Users should log out and log back in for the changes to take effect. We will continue to monitor.
Posted Aug 06, 2026 - 22:00 EDT

Update

The development team is testing the potential fix and hope to move the change into our production environment soon. Will update again once that takes place.
Posted Aug 06, 2026 - 21:01 EDT

Identified

The development team has found the source of the error and will be attempting a fix shortly.  It does take time for the update to get built and deployed (it is essentially another release) , and this is an attempt at a fix and isn't guaranteed to work.  I will update again at 8:00 PM ET.
Posted Aug 06, 2026 - 19:23 EDT

Investigating

We are currently investigating an issue with Powerscribe One. Users are currently unable to connect to the service.
Posted Aug 06, 2026 - 17:47 EDT
This incident affected: Telemedicine (PowerScribe One).