Neo AI Patient History Summarization Outage

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 13:29 EDT

Identified

We’re currently experiencing degraded performance with AI Patient History Summarization. Our team is currently working to restore normal performance. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Sep 02, 2026 - 13:01 EDT
This incident affected: Neo (Neo Software).