AI Assisted Notes: Issue generating transcriptions

Incident Report for IDEXX Software

Resolved

This incident has been resolved and all transcriptions re-generated.
Posted Mar 02, 2026 - 14:58 EST

Monitoring

A fix has been implemented and transcriptions are starting to generate successfully. We are continuing to monitor the system and will begin re-generating failed transcriptions.

We will provide another update once all failed transcriptions have been re-generated.
Posted Mar 02, 2026 - 14:03 EST

Identified

The Neo team is aware of an issue impacting North American customers when generating AI Assisted Notes transcriptions.

We are working on a fix and all transcriptions that failed to generate will be re-generated once the fix has been released.

We will provide another update no later than 5:00PM ET, March 2.
Posted Mar 02, 2026 - 13:36 EST
This incident affected: Neo (Neo Software).