Delayed Results in VetConnect PLUS

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted May 09, 2025 - 09:56 EDT

Update

We are continuing to investigate this issue. Next update will be provided within the next hour.
Posted May 09, 2025 - 09:33 EDT

Investigating

You may experience a delay in viewing or receiving results within VetConnect PLUS. As always, IDEXX appreciates both your business and your patience. We apologize for any inconvenience this may cause and will post an update as soon as we know more.
Posted May 09, 2025 - 08:32 EDT
This incident affected: VetConnect PLUS (Diagnostic Results, Web, Mobile).