Twilio Flex scheduled maintanence - Please be advised that this may impact performance of calls during this time

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 11:35 EDT

Update

We are continuing to investigate this issue.
Posted Jul 25, 2025 - 11:34 EDT

Investigating

Update from Twilio:

MAINTENANCE PERIOD
US Pacific: Jul 25, 06:00 - Jul 25, 08:00
US Central: Jul 25, 08:00 - Jul 25, 10:00
US Eastern: Jul 25, 09:00 - Jul 25, 11:00
UTC: Jul 25, 13:00 - Jul 25, 15:00
Posted Jul 25, 2025 - 08:25 EDT
This incident affected: ezyVet Third Party Integrations (ezyVet/ Vet Radar/ Smartflow Support Ticketing/Phone System).