ezyVet - Twilio Intermittent Telephony Issue - Calls unable to connect

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 15:00 EDT

Investigating

Twilio are currently investing the issue that is impacting our telephony system.
Posted Mar 31, 2025 - 12:45 EDT
This incident affected: ezyVet Third Party Integrations (ezyVet/ Vet Radar/ Smartflow Support Ticketing/Phone System).