Issue configuring/updating special actions in Neo
Incident Report for IDEXX Software
Identified
The Neo Team has identified an issue which is preventing the special action configuration from opening on the product details page. We are working to resolve this issue as soon as possible.

We will provide another update no later than 12:00PM ET, November 21.
Posted Nov 20, 2024 - 17:08 EST
This incident affects: Neo (Neo Software).