Clinics are unable to DICOM sends images to VMS.

Incident Report for IDEXX Software

Resolved

Monitoring is complete. We don't see any issues with image loading, and all downstream connections are live. Thank you for your patience during the extended monitoring period.
Posted May 22, 2026 - 09:01 EDT

Update

We will continue to monitor through the night, but there should no longer be any delays with images loading.
Posted May 21, 2026 - 23:39 EDT

Monitoring

We continue to monitor incoming traffic. Some images are still loading slowly. This may continue for a while longer.
Posted May 21, 2026 - 18:01 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 21, 2026 - 15:53 EDT

Investigating

We are currently investigating an issue with clinics being unable to send Dicom images to VMS.
Posted May 21, 2026 - 15:08 EDT
This incident affected: Telemedicine (VetMedStat, VMS Pro, VMS18, VMS Admin).