This issue has been resolved and the monitoring period has successfully passed. All systems are back to operational levels and functioning as expected.
Thank you for your patience as we worked through resolving this issue.
Posted Oct 20, 2025 - 16:44 EDT
Identified
Our technical team have identified this issue is related to an outage with Amazon Web Services that is impacting ezyVet performance as well as and some of our integration partners such as diagnostic integrations & outgoing communication processing. Our technical team are currently working on mitigating the impact to ezyVet customers where possible and monitoring updates from the Amazon Web Services team as they work through resolution of this incident on their end. We appreciate your continued patience while this situation is ongoing and will provide updates as they come available.
Posted Oct 20, 2025 - 14:31 EDT
Investigating
Our technical team are currently investigating reports of an outage that is occurring with ezyVet in the USE1 region
We apologize for the inconvenience this is causing – we will provide an update as soon as we have more information.
Posted Oct 20, 2025 - 10:29 EDT
This incident affected: ezyVet Software (ezyVet Software: USA and Canada Central/East).