In-House Diagnostic Results Disruption

Incident Report for IDEXX Software

Resolved

Thank you for your patience regarding this issue experienced due to an IDEXX VetConnect Plus feature release that went live on Wednesday, August 20th.

Our technical team have completed work on an update that can be applied to customers' sites as required to pull in any partially returned results due to this issue. As many customers have since manually corrected their results, this update needs to be applied by the ezyVet Support team. If you still have examples of IVLS results that have not returned as expected from the August 20th time period, please contact ezyVet support for assistance to correct these.
Posted Sep 04, 2025 - 02:30 EDT

Identified

We want to inform you of a temporary issue that may have affected some IVLS results in VetConnect PLUS for ezyVet users.

Due to a feature release that went live on Wednesday, August 20th, some in-house diagnostic results processed between 4:00 PM and 10:00 PM EST may have appeared “stuck in process” or remained in a pending state. We’ve since disabled the feature and stabilized the platform. Results are now flowing as expected.

Our team is actively reviewing any remaining IVLS results from that time window and working to ensure they are properly processed.

We appreciate your patience and understanding. If you continue to experience issues, please don’t hesitate to reach out to our support team.
Posted Aug 21, 2025 - 14:50 EDT
This incident affected: VetConnect PLUS (Diagnostic Results) and ezyVet Software (ezyVet Software: USA and Canada West, ezyVet Software: USA and Canada Central/East, ezyVet Software: Australia, ezyVet Software: New Zealand, ezyVet Software: Asia, ezyVet Software: Europe/Middle East/Africa, ezyVet Software: Version Specific).