SmartFlow Investigating Performance Issues

Incident Report for IDEXX Software

Resolved

The issue has been resolved and monitoring has successfully passed. All systems are back to operational levels.

Thank you for your patience as we worked through resolving this issue.
Posted Jun 10, 2025 - 13:11 EDT

Investigating

Our technical team is currently investigating the performance issues that are occurring with some Practice Management Softwares that use a Service Bus Integration with SmartFlow.

We apologize for the inconvenience this is causing - we will provide an update as soon as we have more information.
Posted Jun 09, 2025 - 17:50 EDT
This incident affected: SmartFlow (Integration).