Neo - CareCredit Integration Service Interruption

Incident Report for IDEXX Software

Resolved

The fix has been released and this issue is resolved.

Any transactions processed prior to the fix being released will automatically be allocated in Neo within 60 minutes.
Posted Sep 08, 2025 - 17:47 EDT

Identified

We have identified the cause of the problem and are working on a fix.

Please avoid manually allocating CareCredit payments. CareCredit Integrated payments are automatically being allocated in Neo hourly.

We will provide another update once the fix is released.
Posted Sep 08, 2025 - 16:20 EDT

Investigating

The Neo team is investigating reports of Integrated CareCredit transactions not being applied in Neo.

Please avoid manually allocating CareCredit payments in Neo. Integrated payments will be automatically allocated in Neo once the issue is resolved.

We will post another update as soon as we learn more.
Posted Sep 08, 2025 - 14:15 EDT
This incident affected: Neo (Third Party Integrations).