Neo - 500 Errors When Accessing

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted May 20, 2026 - 11:59 EDT

Monitoring

We have fixed the issue causing the 500 errors and are continuing to monitor.
Posted May 20, 2026 - 08:42 EDT

Investigating

We are investigating an issue causing 500 errors for certain practices when they attempt to log into Neo.
Posted May 20, 2026 - 05:00 EDT
This incident affected: Neo (Neo Software).