(ezyVet) Smartflow Flowsheet Not Returning to ezyVet - Issue Under Investigation

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 16:08 EDT

Investigating

Our technical team have identified an issue and are currently investigating. We are currently working to further understand the problem and diagnose the cause. As we have further information available we will provide additional updates.

We appreciate your patience while we investigate.
Posted Jun 22, 2026 - 14:34 EDT
This incident affected: ezyVet Third Party Integrations (Other Integrations).