DVMInsight - Users are unable to submit cases

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jan 10, 2026 - 21:38 EST

Identified

Users are currently unable to submit cases to DVMInsght. Issue has been identified, and development is currently working on a fix.
Posted Jan 10, 2026 - 19:50 EST
This incident affected: Telemedicine (DVMInsight).