VMS Applications - Unable to load applications

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 20, 2026 - 21:38 EDT

Monitoring

The issue preventing users from loading the application has been resolved. Our team identified the root cause and implemented a fix. All systems are operational, and we are actively monitoring the application to ensure ongoing stability.
Posted Jul 20, 2026 - 20:57 EDT
This incident affected: Telemedicine (VetMedStat, VMS Pro, VMS Admin).