Neo degraded performance

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 16:58 EDT

Monitoring

A fix has been implemented and performance has recovered. We're continuing to monitor the system.
Posted Jul 08, 2026 - 16:25 EDT

Investigating

The Neo team is investigating reports of degraded performance impacting areas such as, but not limited to:

- Sharing patient records
- Displaying diagnostic results

We are working to restore normal performance. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 08, 2026 - 16:14 EDT
This incident affected: Neo (Neo Software).