We appreciate your continued patience. We are still investigating.
We will provide an update no later than 3:45pm ET on March 30th, 2026.
Posted Mar 30, 2026 - 14:45 EDT
Update
We appreciate your continued patience. We are still investigating.
We will provide an update no later than 2:45pm EST on March 30th, 2026.
Posted Mar 30, 2026 - 13:50 EDT
Update
We appreciate your continued patience. We are still investigating.
We will provide an update no later than 1:45pm EST on March 30th, 2026.
Posted Mar 30, 2026 - 12:46 EDT
Update
Web PACS customers may be experiencing difficulty requesting orders, loading images, or sending images to IDEXX Telemedicine using start a consult or sending via Vetmedstat. Our IT team is currently investigating the issue. As always, IDEXX appreciate your business and your patience.
We will provide an update no later than 12:45pm ET.
Posted Mar 30, 2026 - 11:43 EDT
Investigating
Web PACS customers may be experiencing difficulty loading or viewing thumbnail images within the platform. Our IT team is currently investigating the issue. As always, IDEXX appreciate your business and your patience.
We will provide an update no later than 12:00pm ET on March 30, 2026.
Posted Mar 30, 2026 - 10:56 EDT
This incident affects: Telemedicine (VetMedStat, VMS Pro, VMS18, VMS Admin) and Diagnostic Imaging (IDEXX Web PACS, Diagnostic Images, PIMS Ordering).