Results may be temporarily unavailable.

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Apr 06, 2026 - 22:49 EDT

Monitoring

Our service provider has resolved their issue and results are flowing now. We are monitoring as our service recovers, it will take some time for delayed results to catch up.
Posted Apr 06, 2026 - 22:14 EDT

Identified

The team has identified that VetConnect PLUS is being impacted by an incident in a Cloud Service Provider. We are working with our service provider to identify next steps.
Posted Apr 06, 2026 - 22:04 EDT

Investigating

Message content: We appreciate your patience while we fix an issue that may temporarily impact your ability to view results. We hope to resolve the issue as quickly as possible and apologize for any inconvenience. To receive email notifications for service updates, visit status.idexxsoftware.com and subscribe to VetConnect PLUS updates.
Posted Apr 06, 2026 - 21:26 EDT
This incident affected: VetConnect PLUS (Diagnostic Results).