Web PACS/Image Viewer: Unable to View Images

Incident Report for IDEXX Software

Resolved

Image Viewer functionality has been restored. This incident has been resolved.
Posted May 07, 2026 - 21:48 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 20:58 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 07, 2026 - 20:46 EDT

Investigating

We are currently experiencing the inability to allow users to view images within IDEXX Web PACS. We apologize for any inconvenience. Our team is actively working to resolve the issue.
Posted May 07, 2026 - 20:38 EDT
This incident affected: Diagnostic Imaging (IDEXX Web PACS) and Telemedicine (VMS Pro).