Delayed Results in VetConnect PLUS

Incident Report for IDEXX Software

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 16:53 EDT

Investigating

You may experience a delay in viewing or receiving results within VetConnect PLUS and your Integrated Practice Management Software. As always, IDEXX appreciates both your business and your patience. We apologize for any inconvenience this may cause and will post an update as soon as we know more.
Posted Jul 16, 2025 - 13:28 EDT
This incident affected: VetConnect PLUS (Diagnostic Results).