Delay in notifications for online appointments booked in Vello

Incident Report for IDEXX Software

Resolved

All delayed Vello online appointment notifications have been restored within the Vello text message inboxes.
Posted Feb 03, 2026 - 02:38 EST

Monitoring

We have identified an issue affecting Vello practices where text message notifications for appointments booked online (both request and direct bookings) have been delayed for the current business day, 2nd February 2026.

Any appointment request or direct booking made via the Vello portal between 11:00 PM EST yesterday and 5:00 PM EST today has been affected by a delay in notifications sent to the practice’s Vello text message inbox.

Important to note:
Direct bookings during this time did successfully populate the practice management calendar, the issue affects notifications only, not the creation of the appointment itself.
New online bookings made from 5:00PM EST onward are not impacted, and notifications are functioning normally.

We are actively working to restore all delayed notifications and expect them to be delivered within the next few hours.
Posted Feb 02, 2026 - 17:58 EST
This incident affected: Vello (Neo Vello, ezyVet Vello, Cornerstone Vello).